[HOW-TO] Fix LOTD Critical Errors

Tutorials for the UnrealEd(itor) 2.5, which apply to LOTD, UT2003 and UT2004, and other games based on the same Engine.
User avatar Romania
Dragosvr92
Administrator
Administrator
Posts: 1059
Joined: 11 Sep 2009, 06:04
Name: Dragoș-Valentin Rădulescu
Location: Romania
Gender: Male Male
Age: 25
Contact:

[HOW-TO] Fix LOTD Critical Errors

Postby Dragosvr92 » 5 years 9 months ago (21 Oct 2011, 16:51)

Well i have managed to come across a few Errors during the time, and i said to let everyone know how to fix them.
If you have any Critical Errors, post back here and maybe someone will be able to help you fix them.

01, 02, 03, 04, 05, 06, 07, 08, 09, 10, 11, 12, 13, 14, 15, 16, 17, 18, 19, 20, 21, 22, 23, 24

01.

Code: Select all

History: LocalMapURL <- UGameEngine::Browse <- UGameEngine::Init <- InitEngine

This error appears when the map you are trying to Test Play is missing files. Remove the files, or find them to solve it.
To find the missing files, open Editor.log file, push Ctrl+F to open the Find-box. type find file for package and push enter. It will list what files are missing for what package. Error also occurs when you create new files (utx, usx, etc), and you dont save them in the right folders.

02.

Code: Select all

Failed to find object 'Class DOTZGame.ilename to read from'

History: UObject::SafeLoadError <- UObject::StaticLoadClass <- InitGameInfo <- UGameEngine::LoadMap <- LocalMapURL <- UGameEngine::Browse <- UGameEngine::Init <- InitEngine

This error sometime appears if you haven't configured the map gametype in the Editor.
To fix it, Go-to View/Level Properties/LevelInfo/ and paste DOTZGame.DOTZInvasion into the DefaultGameType.

03.

Code: Select all

History: FWaveModInfo::ReadWaveInfo <- callingGetPerioid <- 1 <- FSoundData::Load <- TLazyArray<< <- USound::Serialize <- LoadObject <- (Sound Autoplay.FootSteps.BFootstepDirt1 4113854==4113854/4661290 4113847 8) <- ULinkerLoad::Preload <- PreLoadObjects <- UObject::EndLoad <- UObject::StaticLoadObject <- (Engine.Level None.MyLevel Autoplay.dz) <- LoadLevel <- UGameEngine::LoadMap <- LocalMapURL <- UGameEngine::Browse <- UGameEngine::Init <- InitEngine

This Error Shows up if you embed a sound (.uax) file onto a map while its set into a AmbientSound Actor.

04.

Code: Select all

Negative delta time!

History: UGameEngine::Tick <- UpdateWorld <- MainLoop

It Seems that this Error shows up if you are using a Dual-Core CPU.
To fix it, run the game under the Windows 98 Compability Mode.That way The game will be forced to run under only one core.

05.

Code: Select all

Could not find a starting spot

History: UGameEngine::Init <- InitEngine

To fix it, Load the faulty map in the editor, right click on a surface and click Add Player Start Here.

06.

Code: Select all

History: UALAudioSubsystem::RegisterSound <- UALAudioSubsystem::PlayMusic <- UObject::ProcessEvent <- (DOTZMenuGameType splash.DOTZMenuGameType0, Function DOTZGame.DOTZMenuGameType.PostLogin) <- ULevel::SpawnPlayActor <- UGameEngine::Init <- InitEngine

The error appears if you are running the game under Windows Vista and higher, together with the Vista/7 Editor Fix.
In order to fix this, Find LOTD.ini and set MusicVolume to 0.0 or Roll back to the main Core files.

07.

Code: Select all

Assertion failed: GObjBeginLoadCount==0 [File:.\UnObj.cpp] [Line: 1562]

History: UObject::StaticTick <- UEditorEngine::Tick <- UpdateWorld <- MainLoop
I've met this error while trying to open a .dz file which wasnt completley downloaded.
I think you may also get it while trying to access any broken/corrupt map file.

08.

Code: Select all

History: CheckTag <- ULinkerLoad::ULinkerLoad <- UObject::StaticTick <- UEditorEngine::Tick <- UpdateWorld <- MainLoop

This Error accours when you try to open invalid files into the Editor. For example if you open .exe files, or if you by any chance try to open a .ogg file inside the Sounds tab, where you may only open .uax files

09.

Code: Select all

MountedWeaponA Save.MountedWeaponA1 (Function AdvancedEngine.AdvancedWeapon.NeedsToReload:0001) Runaway loop detected (over 1000000 iterations)

History: FFrame::Serialize <- UObject::ProcessEvent <- (MountedWeaponA Save.MountedWeaponA1, Function AdvancedEngine.AdvancedWeapon.Reloading.BeginState ) <- UObject::GotoState <- AActor::ProcessState <- Object MountedWeaponA Save.MountedWeaponA1, Old State State AdvancedEngine.AdvancedWeapon.Idle, New State State AdvancedEngine.AdvancedWeapon.Reloading <- AActor::Tick <- TickAllActors <- ULevel::Tick <- (NetMode=0) <- TickLevel <- UGameEngine::Tick <- UpdateWorld <- MainLoop

I haven't seen this error in action, but it looks to me that it is occurring when you get into the possession of the Machinegun/Minigun from either Level ch12a, aka Heavy Gunner, or in some cases if use the MINIGUN Cheat in singleplayer.

10.

Code: Select all

Assertion failed: &Mips(MipLevel).DataArray(0) [File:UnTex.cpp] [Line: 1146]

History: UTexture::ConvertDXT

This seems to occur only in singleplayer if you have a Graphics card under 64 MB of RAM.

11.

Code: Select all

DOTZMPFailed Transient.DOTZMPFailed (Function GUI.GUIMultiComponent.Free:004B) Runaway loop detected (over 1000000 iterations)

History: FFrame::Serialize <- UObject::ProcessEvent <- (DOTZPlayerController splash.DOTZPlayerController0, Function Engine.PlayerController.SetProgressMessage) <- UGameEngine::SetProgress <- ULevelBase::NotifyProgress <- UDownload::ReceiveData <- UHTTPDownload::Tick <- TickDownload <- UNetConnection::Tick <- UNetDriver::TickFlush <- UNetPendingLevel::Tick <- TickPending <- UGameEngine::Tick <- UpdateWorld <- MainLoop

This is an Engine bug which occurs on servers that use a fast web redirect. The game was released without the devs intention to have a working redirect. They were surprised to see an old player actually managed to get it to work, but it still had the crashing problem.
Gladly, eBlade fixed this problem with the release of his BladeIM_v12. please follow the instructions to fix it.

  • Make sure you have the BladeIN_V12 files.
  • Open System/LOTD.ini in Notepad
  • Under These Two Sections: [AdvancedEngine.AdvancedGameInfo] AND [DOTZEngine.DOTZGameInfoBase]
    1: Replace: OverridePlayerControllerClass=Class'DOTZEngine.DOTZPlayerController'
    2: With This: OverridePlayerControllerClass=Class'BladeIN_V12.ZPlayerController'

12.

Code: Select all

Can't find 'ini:Engine.Engine.GameEngine' in configuration file

History: UObject::SafeLoadError <- UObject::StaticLoadClass <- InitEngine

The error appears if the group [Engine.Engine] is missing from your LOTD.ini file.
To fix it, just delete the file, and run the game. The game will re-create the original stash file.

13.

Code: Select all

<?int?Engine.Errors.FailedMD5Load?>

History: UGameEngine::Init <- InitEngine

The error appears if the group [Core.System] is missing from your LOTD.ini file.
To fix it, just delete the file, and run the game. The game will re-create the original stash file.
PS: This error, and the one above(12) has to do a bit with the game itself, as it doesnt know how re add them into the file.
Other groups are added in the file, if missing.

14.

Code: Select all

Critical: Assertion failed: Bitmap.LoadFile(Filename) [File:..\..\Engine\Inc\UnEngineWin.h] [Line: 39]
Critical: Windows GetLastError: The system cannot find the file specified. (2)
Exit: Executing UObject::StaticShutdownAfterError

This error will be showing in the LOTD.ini file, and not on the popup window, as the other errors in this topic.
The error shows that the Logo.bmp image is missing from the Help folder, and it will make the game unable to start.
To fix it, put the original image in there, or just place any file named Logo.bmp

15.

Code: Select all

Editor requires desktop set to 32 bit resolution

This error appears when you try to run the Editor, if your pc uses 16bit, and doesn't support 32 bit, or, you have set the compability mode to run into 256 colours.

16.

Code: Select all

History: UObject::GetFullName <- UObject::IsValid <- UObject::GetFullName <- UGameEngine::Draw <- UWindowsViewport::Repaint <- UWindowsClient::Tick <- ClientTick <- UGameEngine::Tick <- UpdateWorld <- MainLoop

This error appears when you try to join game from xfire. To fix it, check the Xfire Fix in this topic.
Everybody should install this to get rid of the starting animations :)

17.

Code: Select all

Assertion failed: GObjBeginLoadCount==0 [File:UnObj.cpp] [Line: 1562]

History: UObject::StaticTick <- UEditorEngine::Tick <- UpdateWorld <- MainLoop

That error shows if you are trying to load all your Textures folder, or if you are trying to load more files than the editor can handle at once. Just load fewer files, like 30 now, 30 later. But i dont see why you would open tens of Gigabytes of textures.

18.

Code: Select all

Can't find 'ini:Engine.Engine.GameEngine' in configuration file

History: UObject::SafeLoadError <- UObject::StaticLoadClass <- InitEngine

Error appears if the server.ini configuration file is missing, or if the [Engine.GameEngine] group doesnt exist in it.
If you create a new ini file with the LOTD Server Config Tool, and you dont save it, the error will pop up.
Always save your ini file after making changes, before running your server.

19.

Code: Select all

Failed to enter Entry: Cannot connect to 'Entry'

History: UGameEngine::Init <- InitEngine

This error appears if you are missing the Entry.dz file from the Levels folder. To fix it, put the file back from your LOTD Disk.

20.

Code: Select all

Can't find 'ini:Engine.Engine.AudioDevice' in configuration file

History: UObject::SafeLoadError <- UObject::StaticLoadClass <- UEngine::InitAudio <- UEditorEngine::InitEditor <- UEditorEngine::Init <- UUnrealEdEngine::Init <- InitEngine

To fix this just delete your LOTD.ini and run the Game. It will create a new file. Or if you want to keep your ini settings and just fix this issue.
Load LOTD.ini in Notepad. Find the group [Engine.Engine] and add this line after AudioDevice=ALAudio.ALAudioSubsystem

21.

Code: Select all

LockRect failed: D3DERR_DEVICELOST

History: UGameEngine::Draw <- UWindowsViewport::Repaint <- UWindowsClient::Tick <- ClientTick <- UGameEngine::Tick <- UpdateWorld <- MainLoop

This error will appear in Windows 8, and Windows 10 when you try to run the game in Fullscreen. To fix it and be able to play in Fullscreen:
1. Open LOTD.ini; 2. Find [D3DDrv.D3DRenderDevice]; 3. Find ReduceMouseLag=True; Change True to False and save the file.
Now you can go play LOTD :) You will have a bit of MouseLag, but it is bearable.

22.

Code: Select all

Can't find file for package 'OpenGLDrv'

History: UObject::SafeLoadError <- UObject::StaticLoadClass <- UGameEngine::Init <- InitEngine

Well, you will only get this error if you want to fix the above error by switching from RenderDevice=D3DDrv.D3DRenderDevice to RenderDevice=OpenGLDrv.OpenGLRenderDevice. LOTD doesnt have an OpenGLDrv.dll and we cant copy it from other games like UT2003-04...
I already tried both.

23.

Code: Select all

ReadFile failed: Count=0 BufferCount=1024 Error=Data error (cyclic redundancy check).

History: ULinkerLoad::Serialize <- TArray<< <- TArray<< <- USkeletalMesh::Serialize <- (SkeletalMesh SamuraisEdgeA.SamuraisEdgeMesh) <- LoadObject <- (SkeletalMesh SamuraisEdgeA.SamuraisEdgeMesh 364544==364544/905025 89888 597542) <- ULinkerLoad::Preload <- PreLoadObjects <- UObject::EndLoad <- UObject::StaticLoadObject <- (Engine.Level INTerminus.MyLevel INTerminus) <- LoadLevel <- UGameEngine::LoadMap <- AttemptLoadPending <- TickPending <- UGameEngine::Tick <- UpdateWorld <- MainLoop

The error means that a needed game file is corrupt. As in the error above, you can see that the corrupt file is SamuraisEdgeA.ukx

24.

Code: Select all

History: UObject::ResetLoaders <- ExitLevel <- UGameEngine::LoadMap <- LocalMapURL <- UGameEngine::Browse <- ClientTravel <- UGameEngine::Tick <- UpdateWorld <- MainLoop

This error appears after a file mismatch is detected. Resolve it by deleting the mismatched file and download it from the server.
If the mismatch is still not resolved after the deteted file, it means the mismatch happens between the server and the redirect.

If you get a myLevel mismatch, that is related to the map on the server being broken. Its for the server owner/mapper to resolve.
Last edited by Dragosvr92 on 08 Dec 2016, 03:27, edited 4 times in total.
0 x
Formerly known as TheKiller
ImageImage

 
User avatar United States of America
DarthTemplar312
LOTD Mapper
LOTD Mapper
Posts: 46
Joined: 23 Jan 2012, 03:11
Location: San Jose
Gender: Male Male
Age: 22

Re: [HOW-TO] Fix General Errors

Postby DarthTemplar312 » 5 years 5 months ago (21 Feb 2012, 06:44)

I think I found a new one... recently I reinstalled my game and I get this demon:

Code: Select all

No Label

OS: Windows 98 4.10 (Build: 67766446)
CPU: GenuineIntel Unknown processor @ 2935 MHz with 503MB RAM
Video: Intel(R) 82915G/GV/910GL Express Chipset Family (3943)

Ran out of virtual memory. To prevent this condition, you must free up more space on your primary hard disk.

History: FMallocWindows::Malloc <- FMallocWindows::Realloc <- 00000000 -391243664 FArray <- FArray::Realloc <- 487965454*8 <- FUnrealfileSummary<< <- LoadSummary <- ULinkerLoad::ULinkerLoad <- UObject::GetPackageLinker <- UObject::StaticLoadObject <- (Engine.Level None.MyLevel Ch01.dz) <- VerifyPackages <- UGameEngine::LoadMap <- LocalMapURL <- UGameEngine::Browse <- ClientTravel <- UGameEngine::Tick <- UpdateWorld <- MainLoop


This only occurs when I play singleplayer, when I play multiplayer it seems fine. Any suggestions? o.o
0 x

User avatar Romania
Dragosvr92
Administrator
Administrator
Posts: 1059
Joined: 11 Sep 2009, 06:04
Name: Dragoș-Valentin Rădulescu
Location: Romania
Gender: Male Male
Age: 25
Contact:

Re: [HOW-TO] Fix General Errors

Postby Dragosvr92 » 5 years 5 months ago (22 Feb 2012, 01:44)

The message is pretty obvious. You got out of virtual memory.
How much freespace do you have on your hard drive? Were you having other programs opened, like Firefox or something else?
Those may have ate RAM memory, i see you have only 503 MB of ram.
Do you really run under Windows 98 !? o-O'
0 x
Formerly known as TheKiller
ImageImage

User avatar United States of America
DarthTemplar312
LOTD Mapper
LOTD Mapper
Posts: 46
Joined: 23 Jan 2012, 03:11
Location: San Jose
Gender: Male Male
Age: 22

Re: [HOW-TO] Fix General Errors

Postby DarthTemplar312 » 5 years 5 months ago (22 Feb 2012, 01:49)

Actually no Lol, I fixed it by replacing the campaign levels with the original, which was able to work. O.o
0 x

User avatar Romania
Dragosvr92
Administrator
Administrator
Posts: 1059
Joined: 11 Sep 2009, 06:04
Name: Dragoș-Valentin Rădulescu
Location: Romania
Gender: Male Male
Age: 25
Contact:

Re: [HOW-TO] Fix General Errors

Postby Dragosvr92 » 5 years 5 months ago (22 Feb 2012, 01:53)

DarthTemplar312 wrote:Actually no Lol, I fixed it by replacing the campaign levels with the original, which was able to work. O.o

humm.. thats weird. So the error was..... ooh.... well, those LOTD_X MODs have lots more of zombies, so your computer seems to have too little RAM to process every zombie with their fast movements. You should try getting some more ram, it got pretty cheap.
0 x
Formerly known as TheKiller
ImageImage

User avatar United States of America
DarthTemplar312
LOTD Mapper
LOTD Mapper
Posts: 46
Joined: 23 Jan 2012, 03:11
Location: San Jose
Gender: Male Male
Age: 22

Re: [HOW-TO] Fix General Errors

Postby DarthTemplar312 » 5 years 5 months ago (22 Feb 2012, 02:00)

Eh.... true the X3 mod does take up a lot of ram, that's' the reason why I uninstalled it. I do try to free up my ram, but the video card update ate 9 MB of my ram, that kinda forced me to uninstall and the video card did causes blue screen on lots of games.

Before Update:
Halo
Star Wars Empire at War
Star Wars Force of Corruption

After Update:
Ate 9 MB of my ram
Halo - Blue Screen
Star Wars Empire at War - Blue Screen
Star Wars Forces of Corruption - Blue Screen
Basically the update would cause almost all the games I own would result into a blue screen which kinda pissed me off.
0 x

User avatar Romania
Dragosvr92
Administrator
Administrator
Posts: 1059
Joined: 11 Sep 2009, 06:04
Name: Dragoș-Valentin Rădulescu
Location: Romania
Gender: Male Male
Age: 25
Contact:

Re: [HOW-TO] Fix General Errors

Postby Dragosvr92 » 5 years 5 months ago (22 Feb 2012, 02:07)

Why do you care about Single Player anyways?
I havent played it in ages, in a time i had the levels deleted as i didnt need them.
0 x
Formerly known as TheKiller
ImageImage

User avatar United States of America
DarthTemplar312
LOTD Mapper
LOTD Mapper
Posts: 46
Joined: 23 Jan 2012, 03:11
Location: San Jose
Gender: Male Male
Age: 22

Re: [HOW-TO] Fix General Errors

Postby DarthTemplar312 » 5 years 5 months ago (22 Feb 2012, 02:10)

I don't know.... I just have to finish the single player first before I play online, same with other games, finish the campaign, understand the story line, understand the characters etc etc, beat the games, then multiplayer. Plus you can understand the maps from singleplayer.
0 x

User avatar
Destroy
Bitten
Bitten
Posts: 15
Joined: 21 Dec 2009, 13:52
Gender: None specified None specified

Re: [HOW-TO] Fix LOTD Critical Errors

Postby Destroy » 5 years 2 months ago (13 Jun 2012, 00:15)

hi there i have an critical error evrey time i connect directly to a server with xfire

Code: Select all

History: UObject::GetFullName <- UObject::IsValid <- UObject::GetFullName <- UGameEngine::Draw <- UWindowsViewport::Repaint <- UWindowsClient::Tick <- ClientTick <- UGameEngine::Tick <- UpdateWorld <- MainLoop



someone knows what i should do to fix it? :O
0 x

User avatar Romania
Dragosvr92
Administrator
Administrator
Posts: 1059
Joined: 11 Sep 2009, 06:04
Name: Dragoș-Valentin Rădulescu
Location: Romania
Gender: Male Male
Age: 25
Contact:

Re: [HOW-TO] Fix LOTD Critical Errors

Postby Dragosvr92 » 5 years 2 months ago (13 Jun 2012, 00:42)

That happens because you dont have the Xfire Fix installed.
I think its because of the starting animations that have to play, and then send you in game server..
Fixed it over Teamviever and added it under the number 16th, on the main list.
0 x
Formerly known as TheKiller
ImageImage


Return to “[HOW-TO]”

Who is online

Users browsing this forum: No registered users and 1 guest

Advertisements: Learn how to write good essays with our free writing tips. Londonwelshschool.org - free homework guide.